Importação de dados

O Expert Advisor Studio fornece uma maneira fácil de carregar seus próprios dados de histórico para testes anteriores. É muito importante criar e testar seu estratégias sobre dados do corretor que você usará mais tarde para negociação. Os diferentes corretores possuem diferentes provedores de dados e fusos horários. Se você usar dados diferentes, é provável que os testes em Expert Advisor Studio e MetaTrader não coincidam.



Scripts de exportação de dados

Na página de importação de dados, fornecemos dois scripts de exportação de dados (MQL). Um para MetaTrader 4 e um para MetaTrader 5.

Aqui está como instalar um script de importação de dados no MetaTrader:

  1. Baixe o script para sua versão do MetaTrader
  2. Ir para Arquivo > Abrir pasta de dados
  3. Na lista, abra o pasta MQL4
  4. Abra o Scripts pasta
  5. Coloque o arquivo baixado no atual ( Scripts) pasta
  6. Volte para MetaTrader
  7. Vá para o Navegador (se não estiver aberto, abra-o Exibir > Navegador)
  8. Clique com o botão direito do mouse no Navegador caixa e use Atualizar no menu.
  9. O script aparecerá na lista.
  10. As etapas abaixo são apenas necessário para MT5 uma vez que não compila novos scripts automaticamente.
  11. No Navegador clique com o botão direito do mouse no nome do script e escolha Modificar
  12. Um editor de código será aberto. Nos botões no menu superior, clique em Compile
  13. Feche a janela do editor de código.

O resultado final deve ser assim:

Script de exportação de dados

Exportar arquivos do MetaTrader

  1. Abra um gráfico
  2. Desative a rolagem automática no novo tiquetaque (Consulte Desativar o deslocamento automático no novo tato abaixo)
  3. Use Ctrl + - para diminuir o gráfico para que mais barras possam ser carregadas de uma só vez
  4. Pressione a tecla Home no seu teclado enquanto as novas barras aparecem à esquerda (este e o anterior permitem carregar todas as barras que seu corretor enviaria ao seu MetaTrader)
  5. Arraste e solte o Script no gráfico. Se tudo estiver funcionando, você deve ver mensagens no gráfico semelhantes ao script de trabalho (veja abaixo)

Desativando o deslocamento automático no novo tico

Desativar rolagem automática

script de trabalho

Arquivos exportados

Importar arquivos para o Expert Advisor Studio

O Script salvará todos os arquivos de dados na pasta MetaTrader MQL * / Files. Para importar os arquivos para o MM Studio

  • Ir para Arquivo > Abrir pasta de dados
  • Na lista, abra o pasta MQL4
  • Abra o Arquivos pasta. Você deve ver vários arquivos JSON nele. Selecione todos os arquivos e arraste e solte-os para o Expert Advisor Studio
Arquivos exportados

O programa mostrará a lista dos arquivos carregados.

Você pode retornar na página Editor e selecionar seu servidor de dados e símbolos. Se você estiver conectado, o aplicativo irá armazene os arquivos na nuvem.